Problem with light at some points...

Talk about Severance Blade of Darkness modifications and maps here. No tips or tech support questions please, use the forum above. Note that the game is rated 18 so some content may be unsuitable for younger readers.

Moderators: Ade, prospero

Sir Random
Dragon
Posts: 737
Joined: Thu Nov 15, 2001 12:58 am
Location: Ireland
Contact:

Postby Sir Random » Sat Mar 26, 2011 8:11 pm

<blockquote id="quote"><font size="1" face="Verdana, Arial, Helvetica" id="quote">quote:<hr height="1" noshade id="quote"><i>Originally posted by prospero</i>

I seem to remember somewhere in the dim and distant past looking at making Conquest saveable. I remember doing Stavros's Vengeance but I think Conquest was a bit more complicated....

I you don't mind me tampering SR, I'll have a go. [:D]
<hr height="1" noshade id="quote"></font id="quote"></blockquote id="quote">
Be my guest!

Feel free to fix any OpenGL bugs you find too! [;)].

Woiwoidata
Whelp
Posts: 13
Joined: Fri Mar 11, 2011 9:10 pm
Location: Bulgaria

Postby Woiwoidata » Sun Mar 27, 2011 2:22 am

About bugs i think i encountered one. In the tight passage where the 3 trolls attack you i got a CTD two times when fighting the second troll with Sargon. Will try again and see if the crash persists... : )


btw, i made a show through of the fugitive 2 walkthrough from big-truck's page - just a simple capture and save in .bmp with some edit in MS paint. Done it for preservation sake couse it's a good info for a good map,worth to be usable offline ;)

if someone need it, here it is - http://www.4shared.com/file/jxe-7WXg/show_through.html

Sir Random
Dragon
Posts: 737
Joined: Thu Nov 15, 2001 12:58 am
Location: Ireland
Contact:

Postby Sir Random » Sun Mar 27, 2011 8:59 pm

<blockquote id="quote"><font size="1" face="Verdana, Arial, Helvetica" id="quote">quote:<hr height="1" noshade id="quote"><i>Originally posted by Woiwoidata</i>

About bugs i think i encountered one. In the tight passage where the 3 trolls attack you i got a CTD two times when fighting the second troll with Sargon. Will try again and see if the crash persists... : )
<hr height="1" noshade id="quote"></font id="quote"></blockquote id="quote">Thanks, I didn't have any problem in the troll cave but I did find some other OpenGL crashes (usually caused by too many fires/lights in view). If prospero can get the Save working I'll try and fix the CTD issues.

User avatar
prospero
Ancient Dragon
Posts: 1725
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Postby prospero » Mon Mar 28, 2011 1:46 am

I've made a start.[:)] I think maybe the graphics level option in the menu isn't needed any more with today's PC power. Any OGL crash bugs are mostly a matter of removing lights. There are some in the main game I've found..... A few in Dal's Tower.

Sir Random
Dragon
Posts: 737
Joined: Thu Nov 15, 2001 12:58 am
Location: Ireland
Contact:

Postby Sir Random » Mon Mar 28, 2011 2:25 am

Yeah, the graphics option is obsolete now.
The only main-game OGL crashes I've come across are in the Amz start map and in the Forge when you meet some dark knights.

User avatar
prospero
Ancient Dragon
Posts: 1725
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Postby prospero » Tue Mar 29, 2011 1:06 pm

Done a bit more.[8D]

Have you still got the MP file SR? Don't really need it desperately but if you have got it, can you tell be the exterior light position? I think you may have the sunflare set to the light settings rather than the light direction.

Going to test run it in a minute. If it works first time it will be a miracle. [:p]

Sir Random
Dragon
Posts: 737
Joined: Thu Nov 15, 2001 12:58 am
Location: Ireland
Contact:

Postby Sir Random » Tue Mar 29, 2011 1:30 pm

Yeah, I still have the MP and the exterior light is set to 128, 128, 128 [?]. I don't know where I got 128 from. As far as I can tell, the light position values should be in the range 0 to PI (half sphere).

User avatar
prospero
Ancient Dragon
Posts: 1725
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Postby prospero » Tue Mar 29, 2011 1:48 pm

That's OK. Just wondered.

Got it running. Not tried saving yet. Just fell off cliff.[:I]

Got a few minor errors cropping up - nothing drastic.

Not made any changes to the basic gameplay but I've fixed the fire arrows so the light from them doesn't cast shadows. Might help later on.... Also put in material sounds. Just had a look at the crows and I think they would look better if I switched the cast shadows off.


Actually.... If you send me the MP file I could tweak the atmos for OGL. Haven't got into the first cave yet, but it appears quite dark outside in the shadows.



That's weird. The crow shadows <i>are</i> turned off in the scripts, but they are still making them[:0]

Sir Random
Dragon
Posts: 737
Joined: Thu Nov 15, 2001 12:58 am
Location: Ireland
Contact:

Postby Sir Random » Tue Mar 29, 2011 2:11 pm

Yeah, there are some basic errors like the GameText() func calls have wrong parameters. I didn't know how to activate the console, so script errors were hard to track down.

Masklin added the menu options at the last minute, but this meant that no armour appeared if you chose a non-default skin. Simple to fix, but very annoying at the time.

There's also a skull shield near the start, no idea how that got there...

Looking at it now, I'm actually amazed that I finished it in 3 months without using the Console or OpenGL viewer. Deadlines are a great motivator!

EDIT\
Ok, I sent the MP file.
I already fixed the dark cave, but the external atmos is grey, maybe yellow/orange would be nicer?

User avatar
prospero
Ancient Dragon
Posts: 1725
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Postby prospero » Tue Mar 29, 2011 2:57 pm

Thanks.[:D]

User avatar
prospero
Ancient Dragon
Posts: 1725
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Postby prospero » Wed Mar 30, 2011 2:37 am

Going OK. Tweaked the atmospheres a bit. Found a few bugettes:

The periodic spirit sounds don't play. I'll look at that later.
The first Great Ork needs to be kept Blind until you can actually get to him or he keeps calling the StdDelayNoSeen func which slows performance. Do that later.

I've mad it so the intro cut plays automatically at the start

The Save works, but the Load has an issue with some of the text variables with a \n in them. Might have to do a complete rewrite of that bit......

There is another non-critical error with the captions. I'll fix that anyway.

Otherwise - all looks good.[8D]

Got rid of the crow shadows.

Sir Random
Dragon
Posts: 737
Joined: Thu Nov 15, 2001 12:58 am
Location: Ireland
Contact:

Postby Sir Random » Wed Mar 30, 2011 2:46 am

Nice one! [:D]

What was up with the crow shadows?

User avatar
prospero
Ancient Dragon
Posts: 1725
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Postby prospero » Wed Mar 30, 2011 3:14 am

They create slowdowns when casting on slopes and they don't really look realistic. I had to move the commands CastShadows=0 to after they are activated.

Just killed the first Mino and got a crash. [:(]

And the Ork textures aren't working for some reason.

Carry on tomorrow.[:)]

User avatar
prospero
Ancient Dragon
Posts: 1725
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Postby prospero » Thu Mar 31, 2011 12:26 pm

Progress....

Just got a game to load. [8D]

At the moment the custom keys don't seem to be working in the save. Can fix that. And there are a few hints that revert to the defaults. Fix that too.

I'm only up to the red maze at the moment.

Strange glitch with the orks. Some seem to have lost their textures - but not all. I have converted them to Dark orks pro temp. That nothing to do with the save thing.

One extra bit. I have replaced the original War Axe with the model that Harrison extracted and added a better collision edge system so you can actually swing it and hit something.

User avatar
prospero
Ancient Dragon
Posts: 1725
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Postby prospero » Thu Mar 31, 2011 1:56 pm

One thing I have noticed and I think it's an OGL issue. Couple of times I have killed enemies with a combo with a fire in view and got a crash. Might have to remove some fires.....

Still having grief with the key bindings...


Return to “Severance BoD: Modding Community”

Who is online

Users browsing this forum: No registered users and 1 guest

cron