My BodLoader has a problem in the beginning!!!

Talk about Severance Blade of Darkness modifications and maps here. No tips or tech support questions please, use the forum above. Note that the game is rated 18 so some content may be unsuitable for younger readers.

Moderators: Ade, prospero

nima207
Dragon
Posts: 73
Joined: Wed May 23, 2012 4:56 pm
Location: Iran
Contact:

My BodLoader has a problem in the beginning!!!

Postby nima207 » Fri Dec 09, 2016 1:13 pm

Hey Guys!

I installed BOD, then the patch, then rOpengl ! Game runs fine, but when i go to MODS in the Main menu, and then select the Setup, to setuping mods, nothing happens ! i can run Maps, but there is no way to setup mods for me :cry: :cry: :cry:

Thanks . . .
If you light a lamp for someone, You lighted your path . . . :wink:

User avatar
prospero
Ancient Dragon
Posts: 1725
Joined: Wed Nov 21, 2001 1:42 am
Location: United Kingdom

Re: My BodLoader has a problem in the beginning!!!

Postby prospero » Fri Dec 09, 2016 3:30 pm

Silly question, but have you any mods in the Mods folder?

nima207
Dragon
Posts: 73
Joined: Wed May 23, 2012 4:56 pm
Location: Iran
Contact:

Re: My BodLoader has a problem in the beginning!!!

Postby nima207 » Fri Dec 09, 2016 5:51 pm

:D Thanks for that "Silly", how did you know that i'm a ritard???? :wink:

yes i have mods in there . . . and still not workin' ! ! !
If you light a lamp for someone, You lighted your path . . . :wink:

nima207
Dragon
Posts: 73
Joined: Wed May 23, 2012 4:56 pm
Location: Iran
Contact:

Re: My BodLoader has a problem in the beginning!!!

Postby nima207 » Sun Dec 11, 2016 7:23 am

Someone help plz, Thanks .
If you light a lamp for someone, You lighted your path . . . :wink:

User avatar
Tomash
Dragon
Posts: 246
Joined: Sat Oct 25, 2008 11:23 am
Location: Russia
Contact:

Re: My BodLoader has a problem in the beginning!!!

Postby Tomash » Mon Dec 12, 2016 3:28 pm

folders names may be wrong

nima207
Dragon
Posts: 73
Joined: Wed May 23, 2012 4:56 pm
Location: Iran
Contact:

Re: My BodLoader has a problem in the beginning!!!

Postby nima207 » Wed Dec 14, 2016 2:43 pm

Which folders??? I don't know if you get that, but i meant that when i press Setup nothing happens! not that i see no modes in Setup tab . . .
Maybe i didn't get what you said ! ! !
But anyway, Thanks bro !
If you light a lamp for someone, You lighted your path . . . :wink:

User avatar
Tomash
Dragon
Posts: 246
Joined: Sat Oct 25, 2008 11:23 am
Location: Russia
Contact:

Re: My BodLoader has a problem in the beginning!!!

Postby Tomash » Wed Dec 14, 2016 3:17 pm

Mods folders

I just did an experiment. I moved all mods in my "Game's Directory/BODLoader/Mods" folder to "Game's Directory/BODLoader/Mods/New Folder" so all mods got wrong path. Then I started the game and when I selected and pressed[MODS][SETUP] I got 'Hit' sound but nothing more. Also console said "Error Creating frame of class MenuWidget.B_MenuTree"

So, it looks similar to your case

User avatar
Tomash
Dragon
Posts: 246
Joined: Sat Oct 25, 2008 11:23 am
Location: Russia
Contact:

Re: My BodLoader has a problem in the beginning!!!

Postby Tomash » Wed Dec 14, 2016 3:24 pm

Check the path of BLModInfo.py. Every mod contains such file and it's path must be "Game's Directory\BODLoader\Mods\Mod's folder\BLModInfo.py". For example: "...\BODLoader\Mods\Allies\BLModInfo.py"

Archive extraction routine may create subfolders so the path become "Game's Directory\BODLoader\Mods\Mod's folder\SUBFOLDER\BLModInfo.py" - such path is wrong

nima207
Dragon
Posts: 73
Joined: Wed May 23, 2012 4:56 pm
Location: Iran
Contact:

Re: My BodLoader has a problem in the beginning!!!

Postby nima207 » Wed Dec 14, 2016 10:10 pm

uh uuhhh . . .
Thanks Tomash bro <3 but nothing worked or happened . . .
nevermind, fuck mods, atleast i can play story for many times and there will be no tiredness for me ! (don't know about you guys)

And ... ummm ... i have a new problem!
Game crashes at the end of amazon's first level, when i open the last door in the late game. . .
and once more in the vampire's level . . .
what the fuck should i do??????? im getting really angry . . .

Thanks again bro, for answering with patience and magnanimity . . .
If you light a lamp for someone, You lighted your path . . . :wink:

User avatar
Tomash
Dragon
Posts: 246
Joined: Sat Oct 25, 2008 11:23 am
Location: Russia
Contact:

Re: My BodLoader has a problem in the beginning!!!

Postby Tomash » Wed Dec 14, 2016 10:33 pm

Most of crashes are caused by dynamic shadows. You can turn them off using Game's menu: [OPTIONS][VIDEO][Character Shadows][No]

nima207
Dragon
Posts: 73
Joined: Wed May 23, 2012 4:56 pm
Location: Iran
Contact:

Re: My BodLoader has a problem in the beginning!!!

Postby nima207 » Wed Dec 14, 2016 10:37 pm

Oh Thanks !
And, i think the game is stretched . . . you know, im playing in 1920x1080 and everything is stretched . . . im using rOpenGL . . .
is there any soloution???
Sorry im wasting your time . . . :cry: Hope you forgive this noob . . .
If you light a lamp for someone, You lighted your path . . . :wink:

User avatar
Tomash
Dragon
Posts: 246
Joined: Sat Oct 25, 2008 11:23 am
Location: Russia
Contact:

Re: My BodLoader has a problem in the beginning!!!

Postby Tomash » Thu Dec 15, 2016 10:08 am

I have 1920x1080 display, but I use 1400x1050 resolution in rOpenGL settings because Game's engine can't produce 16*9 resolution without stretching. Also I use this compatibility settings:
https://pp.vk.me/c623228/v623228821/f96 ... Z1tQsk.jpg

But I'm not sure is it possible in win10

nima207
Dragon
Posts: 73
Joined: Wed May 23, 2012 4:56 pm
Location: Iran
Contact:

Re: My BodLoader has a problem in the beginning!!!

Postby nima207 » Thu Dec 15, 2016 11:12 am

How can i appreciate you big brother?

Bugs almost fixed, but i found something that i didn't mention before!
The game is so laggy ! you know?? when a box broke or someone dies and his limbs throw off, games go so laggy . . .
No problem with my hardware ( :lol: really no problem :lol: ) so what is the soloution??
is there any reference that i could read about these shits, so i don't bother you??
Thanks <3 <3 <3
If you light a lamp for someone, You lighted your path . . . :wink:

User avatar
Tomash
Dragon
Posts: 246
Joined: Sat Oct 25, 2008 11:23 am
Location: Russia
Contact:

Re: My BodLoader has a problem in the beginning!!!

Postby Tomash » Thu Dec 15, 2016 6:00 pm

I have lags only in case of massive trajectory calculating, for example when I break several boxes with one swing, so it is quite rare issue. Also fire arrows may cause lags but such arrows are not presented in original campaign. Some mods can make game laggy as well but you don't use mods. So, the ultimate solution is to use old machine with win XP to play BoD.

nima207
Dragon
Posts: 73
Joined: Wed May 23, 2012 4:56 pm
Location: Iran
Contact:

Re: My BodLoader has a problem in the beginning!!!

Postby nima207 » Fri Dec 16, 2016 3:48 am

Huhh! Thanks bro, i owe you <3
If you light a lamp for someone, You lighted your path . . . :wink:


Return to “Severance BoD: Modding Community”

Who is online

Users browsing this forum: No registered users and 4 guests